aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGabriel Somlo <gsomlo@gmail.com>2022-07-04 13:43:46 -0400
committerGabriel Somlo <gsomlo@gmail.com>2022-07-04 14:54:59 -0400
commit9914f56137e152a46a921f88bc894bbced3d4c27 (patch)
treed15aaade3f6dde37e86c5cd363ff4358e46dcb59 /CMakeLists.txt
parentb4337d99fde46abe85cab8bdf98a681eefe1f3e1 (diff)
downloadnextpnr-9914f56137e152a46a921f88bc894bbced3d4c27.tar.gz
nextpnr-9914f56137e152a46a921f88bc894bbced3d4c27.tar.bz2
nextpnr-9914f56137e152a46a921f88bc894bbced3d4c27.zip
Enable building against unbundled pybind11
Signed-off-by: Gabriel Somlo <gsomlo@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e0001447..3812f7dc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -216,7 +216,12 @@ configure_file(
${CMAKE_CURRENT_SOURCE_DIR}/common/version.h.in ${CMAKE_CURRENT_BINARY_DIR}/generated/version.h
)
-include_directories(common/kernel/ common/place/ common/route/ json/ frontend/ 3rdparty/json11/ 3rdparty/pybind11/include ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})
+if (NOT DEFINED PYBIND11_INCLUDE_DIR)
+ # Use bundled pybind11
+ set(PYBIND11_INCLUDE_DIR "3rdparty/pybind11/include")
+endif()
+
+include_directories(common/kernel/ common/place/ common/route/ json/ frontend/ 3rdparty/json11/ ${PYBIND11_INCLUDE_DIR} ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})
if(BUILD_HEAP)
find_package (Eigen3 REQUIRED NO_MODULE)