aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKeith Rothman <537074+litghost@users.noreply.github.com>2021-01-26 10:05:23 -0800
committerKeith Rothman <537074+litghost@users.noreply.github.com>2021-02-04 16:38:32 -0800
commit561b519716e86576f500dc91b676aad6b6166afc (patch)
treee76767c01bf918ff96d8a37fdfd329be35675597 /CMakeLists.txt
parentc99fbde0eb0b1b9b725ba2fead13d3210ce961a7 (diff)
downloadnextpnr-561b519716e86576f500dc91b676aad6b6166afc.tar.gz
nextpnr-561b519716e86576f500dc91b676aad6b6166afc.tar.bz2
nextpnr-561b519716e86576f500dc91b676aad6b6166afc.zip
Initial FPGA interchange (which is just a cut-down xilinx arch).
Signed-off-by: Keith Rothman <537074+litghost@users.noreply.github.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b6fddcf1..1bfef987 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,9 +66,9 @@ endif()
set(PROGRAM_PREFIX "" CACHE STRING "Name prefix for executables")
# List of families to build
-set(FAMILIES generic ice40 ecp5 nexus gowin)
+set(FAMILIES generic ice40 ecp5 nexus gowin fpga_interchange)
set(STABLE_FAMILIES generic ice40 ecp5)
-set(EXPERIMENTAL_FAMILIES nexus gowin)
+set(EXPERIMENTAL_FAMILIES nexus gowin fpga_interchange)
set(ARCH "" CACHE STRING "Architecture family for nextpnr build")
set_property(CACHE ARCH PROPERTY STRINGS ${FAMILIES})