aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMiodrag Milanovic <mmicko@gmail.com>2018-07-14 14:06:05 +0200
committerMiodrag Milanovic <mmicko@gmail.com>2018-07-14 14:06:05 +0200
commit5216e488639fc8420d38c35177b796e1cf56ac8b (patch)
treec7016df7e88d637a74aaf7a439b4cf39d82f75ed /CMakeLists.txt
parent98c594885698b557311ac84195599b35968719e0 (diff)
downloadnextpnr-5216e488639fc8420d38c35177b796e1cf56ac8b.tar.gz
nextpnr-5216e488639fc8420d38c35177b796e1cf56ac8b.tar.bz2
nextpnr-5216e488639fc8420d38c35177b796e1cf56ac8b.zip
join python and info into one tab
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 78c8b5a2..3ca7935e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,6 +54,10 @@ find_package(Sanitizers)
# List of Boost libraries to include
set(boost_libs filesystem thread program_options)
+if (BUILD_GUI AND NOT BUILD_PYTHON)
+ message(FATAL_ERROR "GUI requires Python to build")
+endif()
+
if (BUILD_PYTHON)
# TODO: sensible minimum Python version
find_package(PythonInterp 3.5 REQUIRED)