aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Shah <dave@ds0.me>2020-11-30 08:59:04 +0000
committerDavid Shah <dave@ds0.me>2020-11-30 08:59:04 +0000
commit2fe8bebc6ce464afadef2403a8331031e16c5a5d (patch)
treeafd13c654df1faa0b5df9f11be74eede087fa564 /CMakeLists.txt
parent567166aeceefc513c498c542873c1533bd73dfbe (diff)
downloadnextpnr-2fe8bebc6ce464afadef2403a8331031e16c5a5d.tar.gz
nextpnr-2fe8bebc6ce464afadef2403a8331031e16c5a5d.tar.bz2
nextpnr-2fe8bebc6ce464afadef2403a8331031e16c5a5d.zip
nexus: Update docs and CMake
Signed-off-by: David Shah <dave@ds0.me>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 29f73f47..baddfb98 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,6 +67,8 @@ set(PROGRAM_PREFIX "" CACHE STRING "Name prefix for executables")
# List of families to build
set(FAMILIES generic ice40 ecp5 nexus)
+set(STABLE_FAMILIES generic ice40 ecp5)
+set(EXPERIMENTAL_FAMILIES nexus)
set(ARCH "" CACHE STRING "Architecture family for nextpnr build")
set_property(CACHE ARCH PROPERTY STRINGS ${FAMILIES})
@@ -75,14 +77,20 @@ if (NOT ARCH)
message(STATUS "Architecture needs to be set, set desired one with -DARCH=xxx")
message(STATUS "Supported architectures are :")
message(STATUS " all")
+ message(STATUS " all+alpha")
foreach(item ${FAMILIES})
message(STATUS " ${item}")
endforeach()
message(FATAL_ERROR "Architecture setting is mandatory")
endif ()
+if (ARCH STREQUAL "all+alpha")
+ SET(ARCH ${STABLE_FAMILIES} ${EXPERIMENTAL_FAMILIES})
+endif()
+
+
if (ARCH STREQUAL "all")
- SET(ARCH ${FAMILIES})
+ SET(ARCH ${STABLE_FAMILIES})
endif()
foreach(item ${ARCH})