aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEddie Hung <eddieh@ece.ubc.ca>2018-07-28 12:51:37 -0700
committerEddie Hung <eddieh@ece.ubc.ca>2018-07-28 12:51:37 -0700
commit0eaa92bd6a160696c2f221501d610c99d9231bef (patch)
tree6f21160deed301364cd866adf9d8dd2244e7c995 /CMakeLists.txt
parente0517caf1aeb520733edb49f13b4ef61923d41f1 (diff)
parent95ac8386542af257e487e2dbe8ad6cfe6e848a21 (diff)
downloadnextpnr-0eaa92bd6a160696c2f221501d610c99d9231bef.tar.gz
nextpnr-0eaa92bd6a160696c2f221501d610c99d9231bef.tar.bz2
nextpnr-0eaa92bd6a160696c2f221501d610c99d9231bef.zip
Merge remote-tracking branch 'origin/master' into redist_slack
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 55e57763..cc712e72 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -191,8 +191,12 @@ foreach (family ${ARCH})
# Add any new per-architecture targets here
if (BUILD_TESTS)
aux_source_directory(tests/${family}/ ${ufamily}_TEST_FILES)
+ if (BUILD_GUI)
+ aux_source_directory(tests/gui/ GUI_TEST_FILES)
+ endif()
- add_executable(nextpnr-${family}-test ${${ufamily}_TEST_FILES} ${COMMON_FILES} ${${ufamily}_FILES})
+ add_executable(nextpnr-${family}-test ${${ufamily}_TEST_FILES}
+ ${COMMON_FILES} ${${ufamily}_FILES} ${GUI_TEST_FILES})
target_link_libraries(nextpnr-${family}-test PRIVATE gtest_main)
add_sanitizers(nextpnr-${family}-test)