aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPatrick Lehmann <Patrick.Lehmann@plc2.de>2020-12-28 23:07:42 +0100
committerPatrick Lehmann <Patrick.Lehmann@plc2.de>2020-12-28 23:07:42 +0100
commitbfd38acc0c6f3f82823fa1a496e90ef1e64da997 (patch)
tree5834b4dc20d5997d1df4338bbe20a37be044e32b /setup.py
parent224f1fa0c327f3fa08a865d6ae79d9cdb1ba19c4 (diff)
downloadghdl-bfd38acc0c6f3f82823fa1a496e90ef1e64da997.tar.gz
ghdl-bfd38acc0c6f3f82823fa1a496e90ef1e64da997.tar.bz2
ghdl-bfd38acc0c6f3f82823fa1a496e90ef1e64da997.zip
setup.py needs the license information twice ...
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 7 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index afb5bc241..7cbb0009e 100644
--- a/setup.py
+++ b/setup.py
@@ -79,7 +79,7 @@ setuptools_setup(
author="Tristan Gingold",
author_email="tgingold@free.fr",
-
+ license="GPL-2.0-or-later",
description="Python binding for GHDL and high-level APIs (incl. LSP).",
long_description=long_description,
long_description_content_type="text/markdown",
@@ -91,12 +91,16 @@ setuptools_setup(
'Issue Tracker': sourceCodeURL + "/issues"
},
- packages=setuptools_find_packages(),
+ python_requires='>=3.8',
+ install_requires=requirements,
+ packages=setuptools_find_packages(exclude=("tests",)),
entry_points={
'console_scripts': [
"ghdl-ls = pyGHDL.cli.lsp:main"
]
},
+
+ keywords="Python3 VHDL Parser Compiler Simulator GHDL",
classifiers=[
"License :: OSI Approved :: GNU General Public License v2 or later (GPLv2+)",
"Operating System :: MacOS",
@@ -113,9 +117,5 @@ setuptools_setup(
"Topic :: Software Development :: Compilers",
"Topic :: Software Development :: Testing",
"Topic :: Utilities",
- ],
- keywords="Python3 VHDL Parser Compiler Simulator GHDL",
-
- python_requires='>=3.8',
- install_requires=requirements,
+ ]
)