aboutsummaryrefslogtreecommitdiffstats
path: root/tests/meson.build
diff options
context:
space:
mode:
authorEdward O'Callaghan <quasisec@google.com>2020-05-20 20:10:20 +1000
committerEdward O'Callaghan <quasisec@chromium.org>2020-06-16 02:22:41 +0000
commit46f2d4e488db66b37e892b8fa621eeed0fe2f284 (patch)
tree515d9dbe880b4942c33c6e1af3d5ce6d0182af91 /tests/meson.build
parent6f793e4500a04b096676555dced98b207e06eeb7 (diff)
downloadflashrom-46f2d4e488db66b37e892b8fa621eeed0fe2f284.tar.gz
flashrom-46f2d4e488db66b37e892b8fa621eeed0fe2f284.tar.bz2
flashrom-46f2d4e488db66b37e892b8fa621eeed0fe2f284.zip
tests/: Add CMocka unit-test infrastructure
This adds the CMocka unit-testing infrastructure into the meson build system which we will latter follow up with unit-tests for flashrom's core logic. BUG=b:157280555 BRANCH=none TEST=builds Change-Id: I66665f56627b3d99049176bfbebbd771b080370a Signed-off-by: Edward O'Callaghan <quasisec@google.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/41622 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Stefan Reinauer <stefan.reinauer@coreboot.org>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 00000000..0c21cb9c
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,28 @@
+root_includes = include_directories('../subprojects')
+
+srcs = [
+ 'tests.c',
+]
+
+mocks = [
+ '-Wl,--wrap=physunmap',
+ '-Wl,--wrap=physmap',
+ '-Wl,--gc-sections',
+]
+
+flashrom_tests = executable('flashrom_unit_tests',
+ srcs,
+ include_directories : root_includes,
+ c_args : [
+ cargs,
+ '-ffunction-sections',
+ '-fdata-sections',
+ # '-DSTANDALONE',
+ '-DCONFIG_DEFAULT_PROGRAMMER=PROGRAMMER_DUMMY',
+ '-DCONFIG_DEFAULT_PROGRAMMER_ARGS=""',
+ ],
+ export_dynamic : true,
+ link_args : mocks,
+ dependencies : [cmocka_dep, flashrom_test_dep],
+)
+test('cmocka test flashrom', flashrom_tests)