aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Heijligen <thomas.heijligen@secunet.com>2023-01-31 00:08:42 +0100
committerThomas Heijligen <src@posteo.de>2023-03-01 09:40:52 +0000
commitf4f2f3dd19784efa26fd5619b7a44b4cdf14b04c (patch)
treec9306c071ccd0fbbbdb7a3f37ea5dfcabf8014cb /meson.build
parentfc533e25623af76d0e6ff87681a7c3122df1607e (diff)
downloadflashrom-f4f2f3dd19784efa26fd5619b7a44b4cdf14b04c.tar.gz
flashrom-f4f2f3dd19784efa26fd5619b7a44b4cdf14b04c.tar.bz2
flashrom-f4f2f3dd19784efa26fd5619b7a44b4cdf14b04c.zip
move manpage to sphinx
Use sphinx (sphinx-doc.org) to generate the UNIX man page from an reStructuredText file instead of dealing with plain groff. Use `meson setup -Dman-pages=enabled` to build the man page, and `meson setup -Ddocumentation=enabled` to build the web documentation explicitly. Both are enabled automatically if sphinx-build is found. The man page will be installed as `<meson_mandir>/man8/flashrom.8` and The html documentation in <meson_datadir>/doc/flashrom/html`. The Makefile builds only the man-page format. Increase the minimum version of meson from 0.53.0 to 0.57.0 to be able to pass environment variables to the custom_target() command. That is needed to pass the FLASHROM_VERSION to the documentation. Change-Id: Iee9f1164c5913e47385e6f7d51dc7775a58b5a67 Signed-off-by: Thomas Heijligen <thomas.heijligen@secunet.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/72619 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Anastasia Klimchuk <aklm@chromium.org> Reviewed-by: Alexander Goncharov <chat@joursoir.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 3 insertions, 12 deletions
diff --git a/meson.build b/meson.build
index d20f24cd..caeea6e6 100644
--- a/meson.build
+++ b/meson.build
@@ -1,7 +1,7 @@
project('flashromutils', 'c',
version : run_command('util/getversion.sh', '--version', check : true).stdout().strip(),
license : 'GPL-2.0',
- meson_version : '>=0.53.0',
+ meson_version : '>=0.57.0',
default_options : [
'warning_level=2',
'c_std=c99',
@@ -11,6 +11,8 @@ project('flashromutils', 'c',
],
)
+subdir('doc')
+
# libtool versioning
lt_current = '1'
lt_revision = '0'
@@ -621,17 +623,6 @@ pkgg.generate(
description : 'library to interact with flashrom',
)
-config_manfile = configuration_data()
-config_manfile.set('VERSION', version)
-config_manfile.set('MAN_DATE', run_command('util/getversion.sh', '--man-date', check : true).stdout().strip())
-configure_file(
- input : 'flashrom.8.tmpl',
- output : 'flashrom.8',
- configuration : config_manfile,
- install: true,
- install_dir: join_paths(get_option('mandir'), 'man8'),
-)
-
if get_option('classic_cli').auto() or get_option('classic_cli').enabled()
classic_cli = executable(
'flashrom',