aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Heijligen <thomas.heijligen@secunet.com>2022-08-13 12:21:44 +0200
committerThomas Heijligen <src@posteo.de>2022-08-23 08:41:54 +0000
commite4137c6913c7a84e5a4a8e0b4fd571d5d0b78616 (patch)
treecf0e292df31e0135e9d33c9527c3ef2690bcb40a /meson.build
parent374871c0393bb1d67c36dc9b7280d8e5f8b22ad5 (diff)
downloadflashrom-e4137c6913c7a84e5a4a8e0b4fd571d5d0b78616.tar.gz
flashrom-e4137c6913c7a84e5a4a8e0b4fd571d5d0b78616.tar.bz2
flashrom-e4137c6913c7a84e5a4a8e0b4fd571d5d0b78616.zip
meson: Build the ich_descriptors_tool as feature
Provide the meson option `-Dich_descriptors_tool=auto/enable/disabled` to determin if the ich_descriptors_tool should be build or not. On `auto` or `enabled` it will be, on `disabled` it will not be build. This is usefull for environments where the ich_descriptors_tool is not needed. Change-Id: Ief65a914019f72536d563eda36bd7f2f5330bea8 Signed-off-by: Thomas Heijligen <thomas.heijligen@secunet.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/66704 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Edward O'Callaghan <quasisec@chromium.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 8eb65a8a..065578e4 100644
--- a/meson.build
+++ b/meson.build
@@ -489,7 +489,9 @@ executable(
link_with : libflashrom.get_static_lib(), # flashrom needs internal symbols of libflashrom
)
-subdir('util')
+if get_option('ich_descriptors_tool').auto() or get_option('ich_descriptors_tool').enabled()
+ subdir('util/ich_descriptors_tool')
+endif
# Use `.auto() or .enabled()` instead of `.allowed()` to keep the minimum meson version as low as possible.
# `.allowed()` gets introduced in 0.59.0