aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Heijligen <thomas.heijligen@secunet.com>2022-03-17 13:41:17 +0100
committerNico Huber <nico.h@gmx.de>2022-04-12 09:55:57 +0000
commitb1db7e4367e3e34140ee12447d7692019d33007a (patch)
treec8a4746d79a4c19841119bccf4c21d93e329e79e /meson.build
parent6272c71fbbfb26ebde9954708f74f875c083f822 (diff)
downloadflashrom-b1db7e4367e3e34140ee12447d7692019d33007a.tar.gz
flashrom-b1db7e4367e3e34140ee12447d7692019d33007a.tar.bz2
flashrom-b1db7e4367e3e34140ee12447d7692019d33007a.zip
Endian conversion: move to platform.h and platform/endian*.c
Starting to move the platform dependent code to platform/ and provide the abstraction through the platform.h header. Change-Id: I35640282d451960f2a329ae24339ec05dbae6d30 Signed-off-by: Thomas Heijligen <thomas.heijligen@secunet.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/62899 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Nico Huber <nico.h@gmx.de>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 0643b5fd..c84c5ded 100644
--- a/meson.build
+++ b/meson.build
@@ -136,11 +136,11 @@ if cc.check_header('sys/utsname.h')
endif
if host_machine.endian() == 'little'
- srcs += 'hwaccess_endian_little.c'
+ srcs += 'platform/endian_little.c'
add_project_arguments('-D__FLASHROM_LITTLE_ENDIAN__=1', language : 'c')
endif
if host_machine.endian() == 'big'
- srcs += 'hwaccess_endian_big.c'
+ srcs += 'platform/endian_big.c'
add_project_arguments('-D__FLASHROM_BIG_ENDIAN__=1', language : 'c')
endif