aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2020-02-17 09:57:01 +0000
committerPatrick Georgi <pgeorgi@google.com>2020-07-15 12:27:40 +0000
commit7aea04f7099ad4dde7b1f5900b54ef603eadf25e (patch)
treeb8ca526e75c99e0dd7b3aef5b5d440d7d7da9a35 /meson.build
parent62027c8e3733f891637fa9c4415af61f997e326c (diff)
downloadflashrom-7aea04f7099ad4dde7b1f5900b54ef603eadf25e.tar.gz
flashrom-7aea04f7099ad4dde7b1f5900b54ef603eadf25e.tar.bz2
flashrom-7aea04f7099ad4dde7b1f5900b54ef603eadf25e.zip
Install the man file when using meson as a buildsystem
This fixes a regression with the Fedora package. Change-Id: I881bd5002a842072ce9dadea033c51a2668f9e7c Signed-off-by: Richard Hughes <richard@hughsie.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/38939 Reviewed-by: Edward O'Callaghan <quasisec@chromium.org> Reviewed-by: Angel Pons <th3fanbus@gmail.com> Reviewed-by: David Hendricks <david.hendricks@gmail.com> Tested-by: build bot (Jenkins) <no-reply@coreboot.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 3d395e86..5374e871 100644
--- a/meson.build
+++ b/meson.build
@@ -321,6 +321,7 @@ endif
prefix = get_option('prefix')
sbindir = join_paths(prefix, get_option('sbindir'))
libdir = join_paths(prefix, get_option('libdir'))
+mandir = join_paths(prefix, get_option('mandir'))
install_headers([
'libflashrom.h',
@@ -394,6 +395,16 @@ pkgg.generate(
description : 'library to interact with flashrom',
)
+conf.set('VERSION', version)
+conf.set('MAN_DATE', run_command('util/getrevision.sh', '--date', 'flashrom.8.tmpl').stdout().strip())
+configure_file(
+ input : 'flashrom.8.tmpl',
+ output : 'flashrom.8',
+ configuration : conf,
+ install: true,
+ install_dir: join_paths(mandir, 'man8'),
+)
+
flashrom_dep = declare_dependency(
link_with : flashrom,
include_directories : include_directories('.'),