aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Heijligen <thomas.heijligen@secunet.com>2022-05-03 11:50:16 +0200
committerThomas Heijligen <src@posteo.de>2022-05-12 08:53:18 +0000
commit688eb58204223dbc2c5a3680cd45d5fd3374bd17 (patch)
tree5deacfe6619caa525b9fe7054fab3c316c1cb864 /meson.build
parent400a6a8b2c7a6fcdbca5397ac0cc58244896732d (diff)
downloadflashrom-688eb58204223dbc2c5a3680cd45d5fd3374bd17.tar.gz
flashrom-688eb58204223dbc2c5a3680cd45d5fd3374bd17.tar.bz2
flashrom-688eb58204223dbc2c5a3680cd45d5fd3374bd17.zip
meson: use built-in options for install paths
The install functions of meson can take a relative path and join the prefix automatically. Change-Id: I9cb9faf4bdbcfd66098478cc3a260eb3b664a2e6 Signed-off-by: Thomas Heijligen <thomas.heijligen@secunet.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/64028 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Edward O'Callaghan <quasisec@chromium.org> Reviewed-by: Anastasia Klimchuk <aklm@chromium.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 2 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index a783bdda..3742a1d6 100644
--- a/meson.build
+++ b/meson.build
@@ -403,11 +403,6 @@ if need_serial
endif
endif
-prefix = get_option('prefix')
-sbindir = join_paths(prefix, get_option('sbindir'))
-libdir = join_paths(prefix, get_option('libdir'))
-mandir = join_paths(prefix, get_option('mandir'))
-
install_headers([
'include/libflashrom.h',
],
@@ -461,7 +456,7 @@ configure_file(
output : 'flashrom.8',
configuration : conf,
install: true,
- install_dir: join_paths(mandir, 'man8'),
+ install_dir: join_paths(get_option('mandir'), 'man8'),
)
flashrom_dep = declare_dependency(
@@ -501,7 +496,7 @@ executable(
cargs
],
install : true,
- install_dir : sbindir,
+ install_dir : get_option('sbindir')
)
subdir('util')