aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Heijligen <thomas.heijligen@secunet.com>2022-08-13 12:10:05 +0200
committerThomas Heijligen <src@posteo.de>2022-09-12 07:14:10 +0000
commit66dc554d7f72860ccb4cf6fcfd0eb89df9a7564f (patch)
tree2dfc551693cf933a98466f879086966d34550a5a /meson.build
parentc696220f97ebc9a72adcb2b56e70ba706a7d88f3 (diff)
downloadflashrom-66dc554d7f72860ccb4cf6fcfd0eb89df9a7564f.tar.gz
flashrom-66dc554d7f72860ccb4cf6fcfd0eb89df9a7564f.tar.bz2
flashrom-66dc554d7f72860ccb4cf6fcfd0eb89df9a7564f.zip
meson: Overhaul the print_wiki option
- Rename `print_wiki` to `classic_cli_print_wiki` - Make it a meson feature type - `classic_cli` must be enabled to enable `classic_cli_print_wiki` - `classic_cli_print_wiki` is disabled by default Change-Id: Ic6c959b8b64ec2756b4535bd1b3320860f836aa5 Signed-off-by: Thomas Heijligen <thomas.heijligen@secunet.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/66703 Reviewed-by: Anastasia Klimchuk <aklm@chromium.org> Reviewed-by: Felix Singer <felixsinger@posteo.net> Tested-by: build bot (Jenkins) <no-reply@coreboot.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 10 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 634e6270..6b00ec2f 100644
--- a/meson.build
+++ b/meson.build
@@ -75,7 +75,7 @@ config_stlinkv3_spi = get_option('config_stlinkv3_spi')
config_parade_lspcon = get_option('config_parade_lspcon')
config_mediatek_i2c_spi = get_option('config_mediatek_i2c_spi')
config_realtek_mst_i2c_spi = get_option('config_realtek_mst_i2c_spi')
-config_print_wiki= get_option('print_wiki')
+config_print_wiki= get_option('classic_cli_print_wiki')
config_default_programmer_name = get_option('default_programmer_name')
config_default_programmer_args = get_option('default_programmer_args')
@@ -409,9 +409,15 @@ if need_serial
endif
endif
-if config_print_wiki
- srcs += files('print_wiki.c')
- cargs += '-DCONFIG_PRINT_WIKI=1'
+
+
+if config_print_wiki.enabled()
+ if get_option('classic_cli').disabled()
+ error('`classic_cli_print_wiki` can not be enabled without `classic_cli`')
+ else
+ srcs += files('print_wiki.c')
+ cargs += '-DCONFIG_PRINT_WIKI=1'
+ endif
endif
if config_default_programmer_name != ''