aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorAnastasia Klimchuk <aklm@chromium.org>2022-04-13 15:15:24 +1000
committerAnastasia Klimchuk <aklm@chromium.org>2022-04-29 05:35:06 +0000
commit2289578807feec8a978d81bbab92615aae76852f (patch)
tree618193368310980680a1e28f0a0ec893dc7edf96 /meson.build
parentd431358621001a75497ebeae32277fcb5ecfc4da (diff)
downloadflashrom-2289578807feec8a978d81bbab92615aae76852f.tar.gz
flashrom-2289578807feec8a978d81bbab92615aae76852f.tar.bz2
flashrom-2289578807feec8a978d81bbab92615aae76852f.zip
meson: Add optimisation level s and disable debug in meson build
Makefile has optimisation level set explicitly. This patch sets the same level s into meson build. Also disable debug by default to correspond to make builds. These two options (optimisation and debug) are linked together in meson build, so they need to be set together to be properly recognised for builds. Alternative approach would be to use buildtype option (and do not set optimisation and debug). However, none of the standard buildtypes gives a combination that we need: optimisation level s and debug disabled. TEST=ninja test shows no warnings and tests pass Change-Id: I4ca96a866529cac320e66516ef280d5100ceefab Signed-off-by: Anastasia Klimchuk <aklm@chromium.org> Reviewed-on: https://review.coreboot.org/c/flashrom/+/63606 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Thomas Heijligen <src@posteo.de>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e9eb4d25..80ccfb38 100644
--- a/meson.build
+++ b/meson.build
@@ -2,7 +2,11 @@ project('flashromutils', 'c',
version : run_command('util/getversion.sh', '--version').stdout().strip(),
license : 'GPL-2.0',
meson_version : '>=0.50.0',
- default_options : ['warning_level=2', 'c_std=c99'],
+ default_options : [
+ 'warning_level=2',
+ 'c_std=c99',
+ 'optimization=s',
+ 'debug=false'],
)
# libtool versioning