aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorFelix Singer <felixsinger@posteo.net>2022-11-29 17:08:03 +0100
committerFelix Singer <felixsinger@posteo.net>2022-12-06 21:22:19 +0000
commit153359935aa52c30f3f9829e740522ce7184469f (patch)
tree082f55593c91d3ab11170143c3124fccd2dced84 /meson.build
parent8390d73806559ceb10894b7302b0dfcb3d71bd0d (diff)
downloadflashrom-153359935aa52c30f3f9829e740522ce7184469f.tar.gz
flashrom-153359935aa52c30f3f9829e740522ce7184469f.tar.bz2
flashrom-153359935aa52c30f3f9829e740522ce7184469f.zip
meson.build: Rename conf object to config_manfile
The config data in the conf object is specific to the man file. Thus, rename it accordingly and also move the declaration to the place where it is used. Change-Id: Icf24b9c47d4c7553f1ec045a9dfd3685b1376445 Signed-off-by: Felix Singer <felixsinger@posteo.net> Reviewed-on: https://review.coreboot.org/c/flashrom/+/70209 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Thomas Heijligen <src@posteo.de>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 4 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 14a84acd..859256fe 100644
--- a/meson.build
+++ b/meson.build
@@ -28,8 +28,6 @@ warning_flags = [
'-Wno-missing-braces',
]
-conf = configuration_data()
-
cc = meson.get_compiler('c')
add_project_arguments(cc.get_supported_arguments(warning_flags), language : 'c')
add_project_arguments('-D_DEFAULT_SOURCE', language : 'c')
@@ -591,12 +589,13 @@ pkgg.generate(
description : 'library to interact with flashrom',
)
-conf.set('VERSION', version)
-conf.set('MAN_DATE', run_command('util/getversion.sh', '--man-date', check : true).stdout().strip())
+config_manfile = configuration_data()
+config_manfile.set('VERSION', version)
+config_manfile.set('MAN_DATE', run_command('util/getversion.sh', '--man-date', check : true).stdout().strip())
configure_file(
input : 'flashrom.8.tmpl',
output : 'flashrom.8',
- configuration : conf,
+ configuration : config_manfile,
install: true,
install_dir: join_paths(get_option('mandir'), 'man8'),
)