aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Heijligen <thomas.heijligen@secunet.com>2023-02-27 16:02:28 +0100
committerThomas Heijligen <src@posteo.de>2023-03-10 15:54:52 +0000
commit0e4d4eac78fbf437ba8e9b1c9d27600d2190023b (patch)
treea8aa31f8bf662347840503ee507cfa21c5f77ebe /meson.build
parentc433910718cf5d5664aab87773ae473061e6b87b (diff)
downloadflashrom-0e4d4eac78fbf437ba8e9b1c9d27600d2190023b.tar.gz
flashrom-0e4d4eac78fbf437ba8e9b1c9d27600d2190023b.tar.bz2
flashrom-0e4d4eac78fbf437ba8e9b1c9d27600d2190023b.zip
libpci: drop support for pciutils < 2.2.0
This version was released in september 2005 and had a breaking api change. Drop it so that we don't need to maintain the old codepath any longer. Beside that, we have already a second codepath which is using the new `pci_get_dev` variant exclusively. Change-Id: If943db350b561a005d8292a53d9255223db3d571 Signed-off-by: Thomas Heijligen <thomas.heijligen@secunet.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/73293 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Anastasia Klimchuk <aklm@chromium.org> Reviewed-by: Angel Pons <th3fanbus@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2ecb5faf..5c38749f 100644
--- a/meson.build
+++ b/meson.build
@@ -126,7 +126,8 @@ group_jlink = get_option('programmer').contains('group_jlink')
group_internal = get_option('programmer').contains('group_internal')
group_external = get_option('programmer').contains('group_external')
-libpci = dependency('libpci', required : group_pci, static : (host_machine.system() == 'openbsd' ? true : false)) # On openbsd a static version of libpci is needed to get also -libz
+libpci = dependency('libpci', required : group_pci, version : '>=2.2.0',
+ static : (host_machine.system() == 'openbsd' ? true : false)) # On openbsd a static version of libpci is needed to get also -libz
libusb1 = dependency('libusb-1.0', required : group_usb)
libftdi1 = dependency('libftdi1', required : group_ftdi)
libjaylink = dependency('libjaylink', required : group_jlink)