aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Kriechbaumer <thomas@kriechbaumer.name>2018-07-27 10:02:52 +0200
committerThomas Kriechbaumer <thomas@kriechbaumer.name>2018-07-27 10:02:52 +0200
commitf3169da3ebec65bf65b71ce2c690132ff90efd59 (patch)
treefcddea18966e6840a9cd8180eb5e70347cc7f4d8 /setup.py
parent8ce963ad4c5a600c220c96957bd2a4bc886b1515 (diff)
downloadmitmproxy-f3169da3ebec65bf65b71ce2c690132ff90efd59.tar.gz
mitmproxy-f3169da3ebec65bf65b71ce2c690132ff90efd59.tar.bz2
mitmproxy-f3169da3ebec65bf65b71ce2c690132ff90efd59.zip
bump dependencies
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 954327e9..65619e8a 100644
--- a/setup.py
+++ b/setup.py
@@ -64,7 +64,7 @@ setup(
"brotlipy>=0.7.0,<0.8",
"certifi>=2015.11.20.1", # no semver here - this should always be on the last release!
"click>=6.2, <7",
- "cryptography>=2.1.4,<2.3",
+ "cryptography>=2.1.4,<2.4",
"h2>=3.0.1,<4",
"hyperframe>=5.1.0,<6",
"kaitaistruct>=0.7,<0.9",
@@ -77,7 +77,7 @@ setup(
"pyperclip>=1.6.0, <1.7",
"ruamel.yaml>=0.13.2, <0.16",
"sortedcontainers>=1.5.4,<2.1",
- "tornado>=4.3,<5.1",
+ "tornado>=4.3,<5.2",
"urwid>=2.0.1,<2.1",
"wsproto>=0.11.0,<0.12.0",
],
@@ -98,7 +98,7 @@ setup(
"pytest-xdist>=1.22,<2",
"pytest>=3.3,<4",
"requests>=2.9.1, <3",
- "tox>=3.0,<3.1",
+ "tox>=3.0,<3.2",
"rstcheck>=2.2, <4.0",
],
'examples': [