aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChih-Hsuan Yen <yan12125@gmail.com>2018-02-24 00:26:49 +0800
committerGitHub <noreply@github.com>2018-02-24 00:26:49 +0800
commitd1ecf9df9431397e5e7e6fee58c7b04c6f37a44b (patch)
tree90fe6c6ea6f90ec910e6ed79c19561a0c92c5ba1 /setup.py
parent8ef2539426235bfee53b438813716bf28dffa209 (diff)
downloadmitmproxy-d1ecf9df9431397e5e7e6fee58c7b04c6f37a44b.tar.gz
mitmproxy-d1ecf9df9431397e5e7e6fee58c7b04c6f37a44b.tar.bz2
mitmproxy-d1ecf9df9431397e5e7e6fee58c7b04c6f37a44b.zip
Explicitly declare pyperclip requirement
pyperclip version 1.6.0 introduces an API change: the class `pyperclip.exceptions.PyperclipException` is moved to `pyperclip.PyperclipException`. As mitmproxy uses the latter, it's better to explicitly declare the requirement.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 1f82dbce..8874b574 100644
--- a/setup.py
+++ b/setup.py
@@ -75,7 +75,7 @@ setup(
"pyasn1>=0.3.1,<0.5",
"pyOpenSSL>=17.5,<17.6",
"pyparsing>=2.1.3, <2.3",
- "pyperclip>=1.5.22, <1.7",
+ "pyperclip>=1.6.0, <1.7",
"requests>=2.9.1, <3",
"ruamel.yaml>=0.13.2, <0.16",
"sortedcontainers>=1.5.4, <1.6",