aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJustus Wingert <justus@abi007.info>2014-11-15 22:37:32 +0100
committerJustus Wingert <justus@abi007.info>2014-11-15 22:37:32 +0100
commitc84ad384f660ba2c04aad3dfd3e7d3b961b013aa (patch)
treee22fdf05f270edb02825139fabcb77e9c6d0c420 /setup.py
parenta7ab06d80eccbe3e58753da0917fca8d55a21c8e (diff)
downloadmitmproxy-c84ad384f660ba2c04aad3dfd3e7d3b961b013aa.tar.gz
mitmproxy-c84ad384f660ba2c04aad3dfd3e7d3b961b013aa.tar.bz2
mitmproxy-c84ad384f660ba2c04aad3dfd3e7d3b961b013aa.zip
Updated setup.py and moved requirements to examples section. Included examples section in requirements.txt. Updated har_extractor to use command line arguments.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 7ea6d0cb..ace5e817 100644
--- a/setup.py
+++ b/setup.py
@@ -28,8 +28,6 @@ script_deps = {
"urwid>=1.1",
"lxml>=3.3.6",
"Pillow>=2.3.0",
- "pytz",
- "harparser",
},
"mitmdump": set()
}
@@ -80,6 +78,10 @@ setup(
"pyamf>=0.6.1",
"protobuf>=2.5.0",
"cssutils>=1.0"
+ ],
+ 'examples': [
+ "pytz",
+ "harparser",
]
}
)