aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAldo Cortesi <aldo@nullcube.com>2018-04-04 14:52:24 +1200
committerAldo Cortesi <aldo@corte.si>2018-04-07 09:04:14 +1200
commit9dcd15d350aa5e2ee2d6f7299d0183cabddeb992 (patch)
treeb02a58edf7402c3f0f9a898a71d9e384bea4ecf2 /setup.py
parent6a08ef465f3af6cb2044baf98279de1071538f5a (diff)
downloadmitmproxy-9dcd15d350aa5e2ee2d6f7299d0183cabddeb992.tar.gz
mitmproxy-9dcd15d350aa5e2ee2d6f7299d0183cabddeb992.tar.bz2
mitmproxy-9dcd15d350aa5e2ee2d6f7299d0183cabddeb992.zip
asyncio: ditch the handler context
There are a few reasons for this. First, logs are now async, and can be called at any time. Second, the event loop is thread local, so there can only ever be one master per thread. These two things together completely obviate the need for a handler context.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 18fb3827..3e914847 100644
--- a/setup.py
+++ b/setup.py
@@ -88,6 +88,7 @@ setup(
"flake8>=3.5, <3.6",
"Flask>=0.10.1, <0.13",
"mypy>=0.580,<0.581",
+ "pytest-asyncio>=0.8",
"pytest-cov>=2.5.1,<3",
"pytest-faulthandler>=1.3.1,<2",
"pytest-timeout>=1.2.1,<2",