aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Kriechbaumer <Kriechi@users.noreply.github.com>2017-10-22 18:06:44 +0200
committerMaximilian Hils <git@maximilianhils.com>2017-10-22 18:06:44 +0200
commit569d275d763f499cce9673fcf118dcc8d59d2eeb (patch)
tree4951103d1a112fbb90059a977582f0642546c4cb /setup.py
parentf31d5dc3ebefec9a88e55354dce6b2f812eb9796 (diff)
downloadmitmproxy-569d275d763f499cce9673fcf118dcc8d59d2eeb.tar.gz
mitmproxy-569d275d763f499cce9673fcf118dcc8d59d2eeb.tar.bz2
mitmproxy-569d275d763f499cce9673fcf118dcc8d59d2eeb.zip
[requires.io] dependency update on master branch (#2586)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 9d8ab79d..9c20cdc9 100644
--- a/setup.py
+++ b/setup.py
@@ -64,7 +64,7 @@ setup(
"brotlipy>=0.5.1, <0.8",
"certifi>=2015.11.20.1", # no semver here - this should always be on the last release!
"click>=6.2, <7",
- "cryptography>=2.0,<2.1",
+ "cryptography>=2.0,<2.2",
"h2>=3.0, <4",
"hyperframe>=5.0, <6",
"kaitaistruct>=0.7, <0.8",
@@ -82,12 +82,12 @@ setup(
],
extras_require={
':sys_platform == "win32"': [
- "pydivert>=2.0.3, <2.1",
+ "pydivert>=2.0.3,<2.2",
],
'dev': [
"flake8>=3.2.1, <3.5",
"Flask>=0.10.1, <0.13",
- "mypy>=0.530,<0.531",
+ "mypy>=0.530,<0.541",
"pytest-cov>=2.2.1, <3",
"pytest-faulthandler>=1.3.0, <2",
"pytest-timeout>=1.0.0, <2",