aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorGuangchao <gwang@brandttechnologies.com>2018-08-17 15:19:29 +0800
committerGuangchao <gwang@brandttechnologies.com>2018-08-17 15:19:29 +0800
commit3f14a485d3e6803d6257d947f508f0eabb35fa1c (patch)
treef522c3fd5322e9ba99158a30976c2ae775d4306d /setup.py
parenta945b0cf1111d81e1adc2aa0239dee9389ca5711 (diff)
downloadmitmproxy-3f14a485d3e6803d6257d947f508f0eabb35fa1c.tar.gz
mitmproxy-3f14a485d3e6803d6257d947f508f0eabb35fa1c.tar.bz2
mitmproxy-3f14a485d3e6803d6257d947f508f0eabb35fa1c.zip
Lib ruamel.yaml version 0.15.55 will caused typing.Sequence[str] unsupported in option.
Baseed on release note of recent version 0.15.55 ruamel.yaml, it unmade CommentedSeq a subclass of list. This will cause the sequence parsed from yaml cannot be set to option whose type is typing.Sequence[str].
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 65619e8a..7c6eb09f 100644
--- a/setup.py
+++ b/setup.py
@@ -75,7 +75,7 @@ setup(
"pyOpenSSL>=17.5,<18.1",
"pyparsing>=2.1.3, <2.3",
"pyperclip>=1.6.0, <1.7",
- "ruamel.yaml>=0.13.2, <0.16",
+ "ruamel.yaml>=0.13.2, <0.15.55",
"sortedcontainers>=1.5.4,<2.1",
"tornado>=4.3,<5.2",
"urwid>=2.0.1,<2.1",