aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMaximilian Hils <git@maximilianhils.com>2015-12-03 19:58:35 +0100
committerMaximilian Hils <git@maximilianhils.com>2015-12-03 19:58:35 +0100
commit37903f69a0e662cd59f4e4a24f3b422a8578f688 (patch)
treeecb2c93d11d2c617dc5186479d45a2fa9c05a27f /setup.py
parent47b2beb48b2d62eb472a542a4bdd1c8070079571 (diff)
downloadmitmproxy-37903f69a0e662cd59f4e4a24f3b422a8578f688.tar.gz
mitmproxy-37903f69a0e662cd59f4e4a24f3b422a8578f688.tar.bz2
mitmproxy-37903f69a0e662cd59f4e4a24f3b422a8578f688.zip
setup.py: document that we don't want to use '~='
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 897906b5..a5963807 100644
--- a/setup.py
+++ b/setup.py
@@ -13,6 +13,8 @@ with open(os.path.join(here, 'README.rst'), encoding='utf-8') as f:
long_description = f.read()
# Core dependencies
+# Do not use the "~=" compatible release specifier.
+# This will break `pip install` on systems with old setuptools versions.
deps = {
"netlib>=%s, <%s" % (version.MINORVERSION, version.NEXT_MINORVERSION),
"tornado>=4.3.0, <4.4",
@@ -23,7 +25,7 @@ deps = {
"html2text==2015.11.4",
"construct>=2.5.2, <2.6",
"six>=1.10.0, <1.11",
- "lxml==3.4.4", # there are no Windows wheels for 3.5!
+ "lxml==3.4.4", # there are no Windows wheels for newer versions, so we pin this.
"Pillow>=3.0.0, <3.1",
"watchdog>=0.8.3, <0.9",
}