aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Kriechbaumer <Kriechi@users.noreply.github.com>2017-07-24 21:03:14 +0200
committerGitHub <noreply@github.com>2017-07-24 21:03:14 +0200
commit28c326031ae49ac988d32fee95abd1c390a0a993 (patch)
tree7c2d62c4c785446c5204459fe2f2d9735236b9a3 /setup.py
parent5c4b0d4132e4332b7d282d7a9b7417940a7d125f (diff)
downloadmitmproxy-28c326031ae49ac988d32fee95abd1c390a0a993.tar.gz
mitmproxy-28c326031ae49ac988d32fee95abd1c390a0a993.tar.bz2
mitmproxy-28c326031ae49ac988d32fee95abd1c390a0a993.zip
[requires.io] dependency update on master branch (#2435)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 7cbfb7ac..c41323ef 100644
--- a/setup.py
+++ b/setup.py
@@ -64,7 +64,7 @@ setup(
"brotlipy>=0.5.1, <0.8",
"certifi>=2015.11.20.1", # no semver here - this should always be on the last release!
"click>=6.2, <7",
- "cryptography>=1.4, <1.10",
+ "cryptography>=2.0,<2.1",
"cssutils>=1.0.1, <1.1",
"h2>=3.0, <4",
"html2text>=2016.1.8, <=2016.9.19",
@@ -74,7 +74,7 @@ setup(
"ldap3>=2.2.0, <2.3",
"passlib>=1.6.5, <1.8",
"pyasn1>=0.1.9, <0.3",
- "pyOpenSSL>=16.0,<17.2",
+ "pyOpenSSL>=17.2,<17.3",
"pyparsing>=2.1.3, <2.3",
"pyperclip>=1.5.22, <1.6",
"requests>=2.9.1, <3",