aboutsummaryrefslogtreecommitdiffstats
path: root/release/mitmweb.spec
diff options
context:
space:
mode:
authorMaximilian Hils <git@maximilianhils.com>2015-11-29 02:48:39 +0100
committerMaximilian Hils <git@maximilianhils.com>2015-11-29 02:48:39 +0100
commit0b06b02c92e3078d886c80e9f15b8740132d26a8 (patch)
tree81c23e7352f6e201f7327ea288d33de4fbf1c57a /release/mitmweb.spec
parent43ed82062f400e9c6e1bf59ce2e3fd29bf0cb09c (diff)
downloadmitmproxy-0b06b02c92e3078d886c80e9f15b8740132d26a8.tar.gz
mitmproxy-0b06b02c92e3078d886c80e9f15b8740132d26a8.tar.bz2
mitmproxy-0b06b02c92e3078d886c80e9f15b8740132d26a8.zip
add new pyinstaller spec files
Diffstat (limited to 'release/mitmweb.spec')
-rw-r--r--release/mitmweb.spec22
1 files changed, 22 insertions, 0 deletions
diff --git a/release/mitmweb.spec b/release/mitmweb.spec
new file mode 100644
index 00000000..e1fea1a3
--- /dev/null
+++ b/release/mitmweb.spec
@@ -0,0 +1,22 @@
+# -*- mode: python -*-
+
+from PyInstaller.utils.hooks import collect_data_files
+
+a = Analysis(['../mitmweb'],
+ binaries=None,
+ datas=collect_data_files("libmproxy"),
+ hiddenimports=[],
+ hookspath=None,
+ runtime_hooks=None,
+ excludes=None)
+pyz = PYZ(a.pure, a.zipped_data)
+exe = EXE(pyz,
+ a.scripts,
+ a.binaries,
+ a.zipfiles,
+ a.datas,
+ name='mitmweb',
+ debug=False,
+ strip=None,
+ upx=True,
+ console=True )