aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 5 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 7d64f993..21475bbb 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,7 +1,10 @@
[build-system]
-# Must be kept in sync with `setup_requirements` in `setup.py`
requires = [
- "setuptools>=18.5",
+ # The minimum setuptools version is specific to the PEP 517 backend,
+ # and may be stricter than the version required in `setup.py`
+ "setuptools>=40.6.0",
"wheel",
+ # Must be kept in sync with the `setup_requirements` in `setup.py`
"cffi>=1.8,!=1.11.3; python_implementation != 'PyPy'",
]
+build-backend = "setuptools.build_meta"