aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPaul Ganssle <pganssle@users.noreply.github.com>2019-02-27 20:22:18 -0500
committerPaul Kehrer <paul.l.kehrer@gmail.com>2019-02-28 09:22:18 +0800
commit0d30f5d5ba23c51e63681309b2acd09b9b998bb3 (patch)
tree450a7eab777927e5f2a754b5c3620b44a9933518 /pyproject.toml
parent2130f898633861c621955eca8473a4d74076cae2 (diff)
downloadcryptography-0d30f5d5ba23c51e63681309b2acd09b9b998bb3.tar.gz
cryptography-0d30f5d5ba23c51e63681309b2acd09b9b998bb3.tar.bz2
cryptography-0d30f5d5ba23c51e63681309b2acd09b9b998bb3.zip
Add PEP 517 to pyproject.toml (#4783)
This puts a new minimum on the PEP 518 requirement for `setuptools` because older versions of setuptools' PEP 517 backend will fail to include `setup.py` in an sdist.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 5 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 7d64f993..21475bbb 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,7 +1,10 @@
[build-system]
-# Must be kept in sync with `setup_requirements` in `setup.py`
requires = [
- "setuptools>=18.5",
+ # The minimum setuptools version is specific to the PEP 517 backend,
+ # and may be stricter than the version required in `setup.py`
+ "setuptools>=40.6.0",
"wheel",
+ # Must be kept in sync with the `setup_requirements` in `setup.py`
"cffi>=1.8,!=1.11.3; python_implementation != 'PyPy'",
]
+build-backend = "setuptools.build_meta"