aboutsummaryrefslogtreecommitdiffstats
path: root/vectors/setup.py
diff options
context:
space:
mode:
authorAlex Stapleton <alexs@prol.etari.at>2014-03-14 20:03:12 +0000
committerAlex Stapleton <alexs@prol.etari.at>2014-03-24 09:46:47 +0000
commita39a319b096b1b2b1775ae1a91117c19422a6c81 (patch)
treeda7d4dbf73d815f835dcf38a4d62d73b742480d2 /vectors/setup.py
parent68e77c752b94c2531f83589c1bb2060c5ed0d886 (diff)
downloadcryptography-a39a319b096b1b2b1775ae1a91117c19422a6c81.tar.gz
cryptography-a39a319b096b1b2b1775ae1a91117c19422a6c81.tar.bz2
cryptography-a39a319b096b1b2b1775ae1a91117c19422a6c81.zip
Move cryptography.vectors to cryptography_vectors
All vectors are now stored in the subpackage in the vectors/ folder. This package is automatically installed by setup.py test and will also be uploaded with a matching version number by the PyPI upload task.
Diffstat (limited to 'vectors/setup.py')
-rw-r--r--vectors/setup.py21
1 files changed, 17 insertions, 4 deletions
diff --git a/vectors/setup.py b/vectors/setup.py
index 773fc456..13b27c7d 100644
--- a/vectors/setup.py
+++ b/vectors/setup.py
@@ -1,3 +1,18 @@
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+from __future__ import absolute_import, division, print_function
+
import os
from setuptools import setup, find_packages
@@ -5,8 +20,7 @@ from setuptools import setup, find_packages
base_dir = os.path.dirname(__file__)
about = {}
-with open(os.path.join(base_dir, "cryptography", "vectors",
- "__about__.py")) as f:
+with open(os.path.join(base_dir, "cryptography_vectors", "__about__.py")) as f:
exec(f.read(), about)
@@ -22,6 +36,5 @@ setup(
packages=find_packages(),
zip_safe=False,
- include_package_data=True,
- namespace_packages=['cryptography'],
+ include_package_data=True
)