aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2018-04-22 10:20:54 -0400
committerPaul Kehrer <paul.l.kehrer@gmail.com>2018-04-22 09:20:54 -0500
commite49bb156565a1042a98638e5cc9bd1b9b4b21ae9 (patch)
treee04cd2677bde05b8f96717189d42f680fc5eec0a /setup.py
parenta63416723afbd7492b11496322fc42ae2efbd51d (diff)
downloadcryptography-e49bb156565a1042a98638e5cc9bd1b9b4b21ae9.tar.gz
cryptography-e49bb156565a1042a98638e5cc9bd1b9b4b21ae9.tar.bz2
cryptography-e49bb156565a1042a98638e5cc9bd1b9b4b21ae9.zip
Remove setup.py branch (#4203)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 1 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 4d7f5c2b..0d715208 100644
--- a/setup.py
+++ b/setup.py
@@ -43,7 +43,7 @@ with open(os.path.join(src_dir, "cryptography", "__about__.py")) as f:
VECTORS_DEPENDENCY = "cryptography_vectors=={0}".format(about['__version__'])
-setup_requirements = []
+setup_requirements = ["cffi>=1.7,!=1.11.3"]
if platform.python_implementation() == "PyPy":
if sys.pypy_version_info < (5, 3):
@@ -51,8 +51,6 @@ if platform.python_implementation() == "PyPy":
"cryptography is not compatible with PyPy < 5.3. Please upgrade "
"PyPy to use this library."
)
-else:
- setup_requirements.append("cffi>=1.7,!=1.11.3")
test_requirements = [
"pytest>=3.2.1,!=3.3.0",