aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2018-03-05 20:50:10 -0400
committerAlex Gaynor <alex.gaynor@gmail.com>2018-03-05 19:50:10 -0500
commite3d2fc1727598bfabb3df78032b83bdccb188681 (patch)
tree2a33f56123f7bee695ab1009ff8fcf7287d3e630 /setup.py
parentef8f066d5a6790a65452e345ae70b8e29af5381e (diff)
downloadcryptography-e3d2fc1727598bfabb3df78032b83bdccb188681.tar.gz
cryptography-e3d2fc1727598bfabb3df78032b83bdccb188681.tar.bz2
cryptography-e3d2fc1727598bfabb3df78032b83bdccb188681.zip
install only the minimum required to build our docs for rtd (#4133)
* install only the minimum required to build our docs for rtd We don't need to install sphinxcontrib-spelling or doc8 in rtd. * move another package
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 800e94d2..b6558163 100644
--- a/setup.py
+++ b/setup.py
@@ -296,12 +296,14 @@ setup(
":platform_python_implementation != 'PyPy'": ["cffi >= 1.7"],
"test": test_requirements,
+ "docs": [
+ "sphinx >= 1.6.5",
+ "sphinx_rtd_theme",
+ ],
"docstest": [
"doc8",
"pyenchant >= 1.6.11",
"readme_renderer >= 16.0",
- "sphinx >= 1.6.5",
- "sphinx_rtd_theme",
"sphinxcontrib-spelling >= 4.0.1",
],
"pep8test": [