aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2016-02-19 07:33:56 -0500
committerAlex Gaynor <alex.gaynor@gmail.com>2016-02-19 07:33:56 -0500
commitde3aa05c45c5144422c9139e385630b1d928b73f (patch)
tree8b8b844bbbf61c5b2dcc6b188514034af2c85471 /setup.py
parentf068325e25dbacd1c12e6b684539320f1ce18c4c (diff)
downloadcryptography-de3aa05c45c5144422c9139e385630b1d928b73f.tar.gz
cryptography-de3aa05c45c5144422c9139e385630b1d928b73f.tar.bz2
cryptography-de3aa05c45c5144422c9139e385630b1d928b73f.zip
Don't try to use hypothesis on Python 2.6, upstream dropped support
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 72675295..88dfd7de 100644
--- a/setup.py
+++ b/setup.py
@@ -61,9 +61,11 @@ test_requirements = [
"pytest",
"pretend",
"iso8601",
- "hypothesis>=1.11.4",
"pyasn1_modules",
]
+if sys.version_info[:2] > (2, 6):
+ test_requirements.append("hypothesis>=1.11.4")
+
# If there's no vectors locally that probably means we are in a tarball and
# need to go and get the matching vectors package from PyPi