aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPeter Odding <peter@peterodding.com>2014-07-12 02:28:13 +0200
committerPaul Kehrer <paul.l.kehrer@gmail.com>2014-09-29 11:44:31 -0500
commitdcce080527d6498eed0a453e73e4e9032b4a87d4 (patch)
treeeb393d426b72e7d1a91368f20f1886ddffea8ee1 /setup.py
parent3ae89a59ad6155363fe195852999a9b669e2b395 (diff)
downloadcryptography-dcce080527d6498eed0a453e73e4e9032b4a87d4.tar.gz
cryptography-dcce080527d6498eed0a453e73e4e9032b4a87d4.tar.bz2
cryptography-dcce080527d6498eed0a453e73e4e9032b4a87d4.zip
Bug fix for implementation of dummy commands
Pointed out by Jenkins: https://jenkins.cryptography.io/job/cryptography-pr-experimental/2163/
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index aa915f0c..ad3ffcfc 100644
--- a/setup.py
+++ b/setup.py
@@ -198,6 +198,9 @@ class DummyCFFIBuild(CFFIBuild):
"""
def finalize_options(self):
+ build.finalize_options(self)
+
+ def run(self):
raise RuntimeError(setup_requires_error)
@@ -209,6 +212,9 @@ class DummyCFFIInstall(CFFIInstall):
"""
def finalize_options(self):
+ install.finalize_options(self)
+
+ def run(self):
raise RuntimeError(setup_requires_error)
@@ -220,7 +226,7 @@ class DummyPyTest(PyTest):
"""
def finalize_options(self):
- raise RuntimeError(setup_requires_error)
+ test.finalize_options(self)
def run_tests(self):
raise RuntimeError(setup_requires_error)