aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2019-12-09 12:42:55 +0800
committerAlex Gaynor <alex.gaynor@gmail.com>2019-12-08 23:42:55 -0500
commitd75335a7de77d4294bea29d03928229a83a77493 (patch)
tree88274e2e17fc56da11298758308dd3eecbb8b6be /setup.py
parent1340c0080c750867297b3f20bbecbad707c18157 (diff)
downloadcryptography-d75335a7de77d4294bea29d03928229a83a77493.tar.gz
cryptography-d75335a7de77d4294bea29d03928229a83a77493.tar.bz2
cryptography-d75335a7de77d4294bea29d03928229a83a77493.zip
drop python 3.4 support (#5087)
* drop python 3.4 support Our dependencies have started dropping support so it is becoming difficult to test. Additionally, Python 3.4 represents <2% of our downloads, so taking on a large maintenance burden to maintain support isn't a good use of limited time. Accordingly, we're dropping testing infrastructure and migrating our abi3 wheels to py35+. * use removed instead of dropped
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index ae01916b..a5bbfa1e 100644
--- a/setup.py
+++ b/setup.py
@@ -217,7 +217,6 @@ setup(
"Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
@@ -231,7 +230,7 @@ setup(
packages=find_packages(where="src", exclude=["_cffi_src", "_cffi_src.*"]),
include_package_data=True,
- python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*',
+ python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*',
install_requires=[
"six >= 1.4.1",