aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPeter Odding <peter@peterodding.com>2014-07-13 04:17:20 +0200
committerPaul Kehrer <paul.l.kehrer@gmail.com>2014-09-29 11:44:32 -0500
commitc9861f9bd496089faf29f2e0022727fcc17e413b (patch)
tree6afbbb1c933f5940ece54c5907f88b9a1be0af70 /setup.py
parente9144566b6fe539256487687dfa5e863f7bdee96 (diff)
downloadcryptography-c9861f9bd496089faf29f2e0022727fcc17e413b.tar.gz
cryptography-c9861f9bd496089faf29f2e0022727fcc17e413b.tar.bz2
cryptography-c9861f9bd496089faf29f2e0022727fcc17e413b.zip
Simplify dummy commands (fix inheritance, remove finalize_options())
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py15
1 files changed, 3 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index 94a18ea8..3dd2bd6e 100644
--- a/setup.py
+++ b/setup.py
@@ -224,44 +224,35 @@ setup_requires_error = ("Requested setup command that needs 'setup_requires' "
"free command or option.")
-class DummyCFFIBuild(CFFIBuild):
+class DummyCFFIBuild(build):
"""
This class makes it very obvious when ``keywords_with_side_effects()`` has
incorrectly interpreted the command line arguments to ``setup.py build`` as
one of the 'side effect free' commands or options.
"""
- def finalize_options(self):
- build.finalize_options(self)
-
def run(self):
raise RuntimeError(setup_requires_error)
-class DummyCFFIInstall(CFFIInstall):
+class DummyCFFIInstall(install):
"""
This class makes it very obvious when ``keywords_with_side_effects()`` has
incorrectly interpreted the command line arguments to ``setup.py install``
as one of the 'side effect free' commands or options.
"""
- def finalize_options(self):
- install.finalize_options(self)
-
def run(self):
raise RuntimeError(setup_requires_error)
-class DummyPyTest(PyTest):
+class DummyPyTest(test):
"""
This class makes it very obvious when ``keywords_with_side_effects()`` has
incorrectly interpreted the command line arguments to ``setup.py test`` as
one of the 'side effect free' commands or options.
"""
- def finalize_options(self):
- test.finalize_options(self)
-
def run_tests(self):
raise RuntimeError(setup_requires_error)