aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorInvalidInterrupt <InvalidInterrupt@users.noreply.github.com>2016-08-16 19:39:31 -0700
committerAlex Gaynor <alex.gaynor@gmail.com>2016-08-16 22:39:31 -0400
commit8e66ca6813016d9fc6f57d5f1e50530fc39f78ae (patch)
tree630a57899cf44a6c98f7928c065da04f16504267 /setup.py
parentdcbd220ee6b4e23f292897e1d6b1e26004ecfd64 (diff)
downloadcryptography-8e66ca6813016d9fc6f57d5f1e50530fc39f78ae.tar.gz
cryptography-8e66ca6813016d9fc6f57d5f1e50530fc39f78ae.tar.bz2
cryptography-8e66ca6813016d9fc6f57d5f1e50530fc39f78ae.zip
CertificateBuilder accepts aware datetimes for not_valid_after and not_valid_before (#2920)
* CertificateBuilder accepts aware datetimes for not_valid_after and not_valid_before These functions now accept aware datetimes and convert them to UTC * Added pytz to test requirements * Correct pep8 error and improve Changelog wording * Improve tests and clarify changelog message * Trim Changelog line length * Allow RevokedCertificateBuilder and CertificateRevocationListBuilder to accept aware datetimes * Fix accidental changelog entry
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 3bacae7b..b5c05dfb 100644
--- a/setup.py
+++ b/setup.py
@@ -62,6 +62,7 @@ test_requirements = [
"pretend",
"iso8601",
"pyasn1_modules",
+ "pytz",
]
if sys.version_info[:2] > (2, 6):
test_requirements.append("hypothesis>=1.11.4")