aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2015-02-20 07:58:39 -0800
committerAlex Gaynor <alex.gaynor@gmail.com>2015-02-20 07:58:39 -0800
commit8a58e6997b8b4abfed11a8a23b539e261fde1a28 (patch)
tree2c965d42fd14130a6ef4c83ce02a30251311da33 /setup.py
parent8be38b39270d4545bb303eb08fa5e84940de04a2 (diff)
downloadcryptography-8a58e6997b8b4abfed11a8a23b539e261fde1a28.tar.gz
cryptography-8a58e6997b8b4abfed11a8a23b539e261fde1a28.tar.bz2
cryptography-8a58e6997b8b4abfed11a8a23b539e261fde1a28.zip
Tell py.test to only run the tests from the local tests dir.
Right now if you have a virtualenv or something in the same directory it will recurse into it to run tests.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 32a87ba3..2324d54f 100644
--- a/setup.py
+++ b/setup.py
@@ -135,7 +135,8 @@ class PyTest(test):
def run_tests(self):
# Import here because in module scope the eggs are not loaded.
import pytest
- errno = pytest.main(self.test_args)
+ test_args = [os.path.join(base_dir, "tests")]
+ errno = pytest.main(test_args)
sys.exit(errno)