aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2015-11-19 16:18:04 +0100
committerPaul Kehrer <paul.l.kehrer@gmail.com>2016-01-07 11:38:34 -0800
commit830af271de1c9c3589bcce12cc08573850141f51 (patch)
treecf637035244e6c0de8edef31b4161cbe23f1f39f /setup.py
parent7d79649e8d9fc6a4994c814022c5b584ef2670f7 (diff)
downloadcryptography-830af271de1c9c3589bcce12cc08573850141f51.tar.gz
cryptography-830af271de1c9c3589bcce12cc08573850141f51.tar.bz2
cryptography-830af271de1c9c3589bcce12cc08573850141f51.zip
Port callbacks to new static callback
cffi 1.4.0 will introduce a new API to create static callbacks. Contrary to the old callback API, static callbacks no longer depend on libffi's dynamic code generation for closures. Static code has some benefits over dynamic generation. For example the code is faster. Also it doesn't need writeable and executable memory mappings, which makes it compatible with SELinux's deny execmem policy. The branch depends on PR #2488. https://bitbucket.org/cffi/cffi/issues/232/static-callbacks Closes: #2477 Signed-off-by: Christian Heimes <cheimes@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 3b67e8ff..f79b0e25 100644
--- a/setup.py
+++ b/setup.py
@@ -54,8 +54,8 @@ if platform.python_implementation() == "PyPy":
"upgrade PyPy to use this library."
)
else:
- requirements.append("cffi>=1.1.0")
- setup_requirements.append("cffi>=1.1.0")
+ requirements.append("cffi>=1.4.1")
+ setup_requirements.append("cffi>=1.4.1")
# If you add a new dep here you probably need to add it in the tox.ini as well
test_requirements = [