aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2018-12-07 11:43:38 +0800
committerAlex Gaynor <alex.gaynor@gmail.com>2018-12-06 22:43:38 -0500
commit7e422821b9f800f5345c37011c510dc9e76f552c (patch)
tree684836bedeb4ae9d898a014068f1555cd25c58aa /setup.py
parentfec719b60441b1e69bcca26446b8025bb69ee1fd (diff)
downloadcryptography-7e422821b9f800f5345c37011c510dc9e76f552c.tar.gz
cryptography-7e422821b9f800f5345c37011c510dc9e76f552c.tar.bz2
cryptography-7e422821b9f800f5345c37011c510dc9e76f552c.zip
remove idna as a primary dependency (#4624)
* remove idna as a primary dependency * empty commit * dynamodb test fix (thanks to Matt Bullock) * review feedback
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 937d1ac5..bd98fd5e 100644
--- a/setup.py
+++ b/setup.py
@@ -287,7 +287,6 @@ setup(
python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*',
install_requires=[
- "idna >= 2.1",
"asn1crypto >= 0.21.0",
"six >= 1.4.1",
] + setup_requirements,
@@ -311,6 +310,12 @@ setup(
"flake8-import-order",
"pep8-naming",
],
+ # This extra is for the U-label support that was deprecated in
+ # cryptography 2.1. If you need this deprecated path install with
+ # pip install cryptography[idna]
+ "idna": [
+ "idna >= 2.1",
+ ]
},
# for cffi