aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorTerry Chia <terrycwk1994@gmail.com>2015-03-22 11:49:08 +0800
committerTerry Chia <terrycwk1994@gmail.com>2015-09-26 22:31:53 +0800
commit5cec1bf1b644c33cffe96e8f8ebd11a1a343bc6d (patch)
tree0950e4607d93287bc0f48b51e2c3b82b9e686ed5 /setup.py
parent3f3f20c7b429a19819e90e0bb181c5895e18c7dc (diff)
downloadcryptography-5cec1bf1b644c33cffe96e8f8ebd11a1a343bc6d.tar.gz
cryptography-5cec1bf1b644c33cffe96e8f8ebd11a1a343bc6d.tar.bz2
cryptography-5cec1bf1b644c33cffe96e8f8ebd11a1a343bc6d.zip
Add plumbing for hypothesis.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index b36f3de6..ea2ea181 100644
--- a/setup.py
+++ b/setup.py
@@ -62,6 +62,10 @@ test_requirements = [
"iso8601",
]
+if sys.version_info[:2] == (2, 6):
+ test_requirements.append("hypothesis")
+ test_requirements.append("hypothesis-pytest")
+
# If there's no vectors locally that probably means we are in a tarball and
# need to go and get the matching vectors package from PyPi
if not os.path.exists(os.path.join(base_dir, "vectors/setup.py")):