aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2015-10-19 23:45:59 -0500
committerPaul Kehrer <paul.l.kehrer@gmail.com>2015-10-20 11:13:07 -0500
commit5a2bb54bbb7b68a7407ab5d62c828c329166bd81 (patch)
treec2de009d37d9f1603dd66914bf9f6f3a4f12aa4a /setup.py
parent08801cd1bacf08aa4d4a833ff235574f4da15a20 (diff)
downloadcryptography-5a2bb54bbb7b68a7407ab5d62c828c329166bd81.tar.gz
cryptography-5a2bb54bbb7b68a7407ab5d62c828c329166bd81.tar.bz2
cryptography-5a2bb54bbb7b68a7407ab5d62c828c329166bd81.zip
encode countryName with PrintableString
This commit adds a dependency on asn1crypto for testing purposes to parse the certificate and confirm that countryName is encoded with PrintableString while other fields are UTF8String. This is a test only dep.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9c97e1dd..d54afc02 100644
--- a/setup.py
+++ b/setup.py
@@ -63,6 +63,7 @@ test_requirements = [
"pretend",
"iso8601",
"hypothesis",
+ "asn1crypto",
]
# If there's no vectors locally that probably means we are in a tarball and