aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2017-05-20 10:09:02 -0700
committerAlex Gaynor <alex.gaynor@gmail.com>2017-05-20 10:09:02 -0700
commit51032351297b9bf7d783b7138ac0c142d8e38918 (patch)
tree3a3ca718dbb0cf904d66b9046489185349ba508b /setup.py
parentd08ddd5af21de62088c0236bfac1d647a6cb84a2 (diff)
downloadcryptography-51032351297b9bf7d783b7138ac0c142d8e38918.tar.gz
cryptography-51032351297b9bf7d783b7138ac0c142d8e38918.tar.bz2
cryptography-51032351297b9bf7d783b7138ac0c142d8e38918.zip
time to remove commoncrypto, fare thee well (#3551)
* time to remove commoncrypto, fare thee well * remove even more * update the changelog * remove more things * don't need this function * remove CAST5 CTR tests since that was only supported in commoncrypto * assert a thing
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 0 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index e5e6949e..586ea48d 100644
--- a/setup.py
+++ b/setup.py
@@ -73,20 +73,10 @@ if not os.path.exists(os.path.join(base_dir, "vectors/setup.py")):
test_requirements.append(VECTORS_DEPENDENCY)
-def cc_is_available():
- return sys.platform == "darwin" and list(map(
- int, platform.mac_ver()[0].split("."))) >= [10, 8, 0]
-
-
backends = [
"openssl = cryptography.hazmat.backends.openssl:backend"
]
-if cc_is_available():
- backends.append(
- "commoncrypto = cryptography.hazmat.backends.commoncrypto:backend",
- )
-
class PyTest(test):
def finalize_options(self):
@@ -212,8 +202,6 @@ def keywords_with_side_effects(argv):
"src/_cffi_src/build_constant_time.py:ffi",
"src/_cffi_src/build_padding.py:ffi",
]
- if cc_is_available():
- cffi_modules.append("src/_cffi_src/build_commoncrypto.py:ffi")
return {
"setup_requires": setup_requirements,