aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2017-10-12 06:06:01 +0800
committerAlex Gaynor <alex.gaynor@gmail.com>2017-10-11 18:06:01 -0400
commit4cf6e785ca5608cffd8d92ad1e1a5073108a2a20 (patch)
treeeca2e7ce6043f94cbb8034ee3ad95aaf45bdcf41 /setup.py
parent38fe038522651fd18eeae60d5e96dc81aa07e863 (diff)
downloadcryptography-4cf6e785ca5608cffd8d92ad1e1a5073108a2a20.tar.gz
cryptography-4cf6e785ca5608cffd8d92ad1e1a5073108a2a20.tar.bz2
cryptography-4cf6e785ca5608cffd8d92ad1e1a5073108a2a20.zip
expunge python 2.6 (#3962)
* expunge python 2.6 * how did THAT happen * remove another unsupported python from the tox envlist * hypothesis can now be unconditionally imported
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 1 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index c5a42b20..cf79b661 100644
--- a/setup.py
+++ b/setup.py
@@ -49,9 +49,8 @@ test_requirements = [
"pretend",
"iso8601",
"pytz",
+ "hypothesis>=1.11.4",
]
-if sys.version_info[:2] > (2, 6):
- test_requirements.append("hypothesis>=1.11.4")
# If there's no vectors locally that probably means we are in a tarball and
@@ -260,7 +259,6 @@ setup(
"Operating System :: Microsoft :: Windows",
"Programming Language :: Python",
"Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.4",