aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJulian Berman <Julian@GrayVines.com>2015-02-24 10:51:53 -0500
committerJulian Berman <Julian@GrayVines.com>2015-03-08 18:27:29 -0400
commit4cf381137643c2d78e8631f3f439daef62a97a67 (patch)
treed01de26528e0b07e00b47adc6c9a857c42e3177e /setup.py
parent4733b47c9a6da998f01aee77c0ffb8c3bb321f5c (diff)
downloadcryptography-4cf381137643c2d78e8631f3f439daef62a97a67.tar.gz
cryptography-4cf381137643c2d78e8631f3f439daef62a97a67.tar.bz2
cryptography-4cf381137643c2d78e8631f3f439daef62a97a67.zip
Remove the setuptools and CFFI requirements, which break pip install -U
PyPy ships with CFFI, but pip install -U will upgrade it if a newer CFFI is available, which will break the CFFI installation (and PyPy itself).
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 2324d54f..d8c0790f 100644
--- a/setup.py
+++ b/setup.py
@@ -35,7 +35,6 @@ SIX_DEPENDENCY = "six>=1.4.1"
VECTORS_DEPENDENCY = "cryptography_vectors=={0}".format(about['__version__'])
requirements = [
- CFFI_DEPENDENCY,
"pyasn1",
SIX_DEPENDENCY,
SETUPTOOLS_DEPENDENCY
@@ -44,6 +43,9 @@ requirements = [
if sys.version_info < (3, 4):
requirements.append("enum34")
+if platform.python_implementation() != "PyPy":
+ requirements.append(CFFI_DEPENDENCY)
+
# If you add a new dep here you probably need to add it in the tox.ini as well
test_requirements = [
"pytest",