aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2017-08-23 20:33:01 -0400
committerPaul Kehrer <paul.l.kehrer@gmail.com>2017-08-24 08:33:01 +0800
commit4c41ab087d4fa741ced2a8aba6fd38b20137f42b (patch)
tree96a97ecc95d9a3db32ce3b07304d236ba73bbedf /setup.py
parent13e9a6f9e98635d694310e87af7b82d180e486e7 (diff)
downloadcryptography-4c41ab087d4fa741ced2a8aba6fd38b20137f42b.tar.gz
cryptography-4c41ab087d4fa741ced2a8aba6fd38b20137f42b.tar.bz2
cryptography-4c41ab087d4fa741ced2a8aba6fd38b20137f42b.zip
Switch to using the other style of environment markers (#3796)
* Switch to using the other style of environment markers * We don't do py3.3 any more! * changelog
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py19
1 files changed, 8 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index fbc7f22b..692313fb 100644
--- a/setup.py
+++ b/setup.py
@@ -33,17 +33,8 @@ with open(os.path.join(src_dir, "cryptography", "__about__.py")) as f:
VECTORS_DEPENDENCY = "cryptography_vectors=={0}".format(about['__version__'])
-requirements = [
- "idna>=2.1",
- "asn1crypto>=0.21.0",
- "six>=1.4.1",
-]
setup_requirements = []
-if sys.version_info < (3,):
- requirements.append("enum34")
- requirements.append("ipaddress")
-
if platform.python_implementation() == "PyPy":
if sys.pypy_version_info < (5, 3):
raise RuntimeError(
@@ -51,7 +42,6 @@ if platform.python_implementation() == "PyPy":
"upgrade PyPy to use this library."
)
else:
- requirements.append("cffi>=1.7")
setup_requirements.append("cffi>=1.7")
test_requirements = [
@@ -285,9 +275,16 @@ setup(
packages=find_packages(where="src", exclude=["_cffi_src", "_cffi_src.*"]),
include_package_data=True,
- install_requires=requirements,
+ install_requires=[
+ "idna >= 2.1",
+ "asn1crypto >= 0.21.0",
+ "six >= 1.4.1",
+ ],
tests_require=test_requirements,
extras_require={
+ ":python_version < '3'": ["enum34", "ipaddress"],
+ ":python_implementation != 'PyPy'": ["cffi >= 1.7"],
+
"test": test_requirements,
"docstest": [
"doc8",