aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2015-06-08 00:05:53 -0500
committerPaul Kehrer <paul.l.kehrer@gmail.com>2015-06-08 00:05:53 -0500
commit4c287d704ff716769348019266c26814dfb90b37 (patch)
tree59fe7d4ef7e1351ae9bf95c442ae93455f004809 /setup.py
parent4ff26abc0f48db53fcc0b321162a7129fd7fbdc6 (diff)
downloadcryptography-4c287d704ff716769348019266c26814dfb90b37.tar.gz
cryptography-4c287d704ff716769348019266c26814dfb90b37.tar.bz2
cryptography-4c287d704ff716769348019266c26814dfb90b37.zip
setup requires can be cffi only now
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 2f950b78..4cd3b51a 100644
--- a/setup.py
+++ b/setup.py
@@ -37,6 +37,7 @@ requirements = [
"six>=1.4.1",
"setuptools"
]
+setup_requirements = []
if sys.version_info < (3, 4):
requirements.append("enum34")
@@ -46,6 +47,7 @@ if sys.version_info < (3, 3):
if platform.python_implementation() != "PyPy":
requirements.append("cffi>=1.1.0")
+ setup_requirements.append("cffi>=1.1.0")
# If you add a new dep here you probably need to add it in the tox.ini as well
test_requirements = [
@@ -203,7 +205,7 @@ def keywords_with_side_effects(argv):
cffi_modules.append("src/_cffi_src/build_commoncrypto.py:ffi")
return {
- "setup_requires": requirements,
+ "setup_requires": setup_requirements,
"cmdclass": {
"test": PyTest,
},