aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2015-04-13 09:50:31 -0400
committerAlex Gaynor <alex.gaynor@gmail.com>2015-04-13 09:50:31 -0400
commit2119f745959b8a5402df68a9b2f3342f1fe8eb6a (patch)
treecceb52fa1563937760a24fed5de1b2ff1ea356ee /setup.py
parent249bbd0064d42d78ff51e9a0203db4492453418f (diff)
downloadcryptography-2119f745959b8a5402df68a9b2f3342f1fe8eb6a.tar.gz
cryptography-2119f745959b8a5402df68a9b2f3342f1fe8eb6a.tar.bz2
cryptography-2119f745959b8a5402df68a9b2f3342f1fe8eb6a.zip
Simplify setup.py slightly
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 3 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index d8c0790f..eb735a04 100644
--- a/setup.py
+++ b/setup.py
@@ -29,22 +29,19 @@ with open(os.path.join(src_dir, "cryptography", "__about__.py")) as f:
exec(f.read(), about)
-SETUPTOOLS_DEPENDENCY = "setuptools"
-CFFI_DEPENDENCY = "cffi>=0.8"
-SIX_DEPENDENCY = "six>=1.4.1"
VECTORS_DEPENDENCY = "cryptography_vectors=={0}".format(about['__version__'])
requirements = [
"pyasn1",
- SIX_DEPENDENCY,
- SETUPTOOLS_DEPENDENCY
+ "six>=1.4.1",
+ "setuptools"
]
if sys.version_info < (3, 4):
requirements.append("enum34")
if platform.python_implementation() != "PyPy":
- requirements.append(CFFI_DEPENDENCY)
+ requirements.append("cffi>=0.8")
# If you add a new dep here you probably need to add it in the tox.ini as well
test_requirements = [