aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Reid <dreid@dreid.org>2014-07-11 12:36:21 -0700
committerDavid Reid <dreid@dreid.org>2014-07-11 12:36:21 -0700
commit1872e75fea4b9acf591707ad1da203909ea0bd5f (patch)
tree68ca2a2f3a1cf8954b2c372a34a8157c38f694e5 /setup.py
parentcb70d20e55330ab1027fa74674b03f7d593b6bb7 (diff)
parentd9f9b75ad6514bb184dd6803d57d7f3f805ffb96 (diff)
downloadcryptography-1872e75fea4b9acf591707ad1da203909ea0bd5f.tar.gz
cryptography-1872e75fea4b9acf591707ad1da203909ea0bd5f.tar.bz2
cryptography-1872e75fea4b9acf591707ad1da203909ea0bd5f.zip
Merge pull request #1254 from alex/check-for-errors
Check for errors when invoking the vectors setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 4dd9e629..f73394ee 100644
--- a/setup.py
+++ b/setup.py
@@ -110,8 +110,9 @@ class PyTest(test):
# This means there's a vectors/ folder with the package in here.
# cd into it, install the vectors package and then refresh sys.path
if VECTORS_DEPENDENCY not in test_requirements:
- subprocess.Popen([sys.executable, "setup.py", "install"],
- cwd="vectors").communicate()
+ subprocess.check_call(
+ [sys.executable, "setup.py", "install"], cwd="vectors"
+ )
pkg_resources.get_distribution("cryptography_vectors").activate()
def run_tests(self):