aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2017-12-26 13:04:31 -0500
committerPaul Kehrer <paul.l.kehrer@gmail.com>2017-12-26 12:04:31 -0600
commit0ed80b467df9565aa06ff79130f121effe0bd82a (patch)
tree4510648281dc7d3b7c0ddf7aa6f0ee4b682ed802 /setup.py
parent25905566118da4264001350525fec7dc2fbbfa94 (diff)
downloadcryptography-0ed80b467df9565aa06ff79130f121effe0bd82a.tar.gz
cryptography-0ed80b467df9565aa06ff79130f121effe0bd82a.tar.bz2
cryptography-0ed80b467df9565aa06ff79130f121effe0bd82a.zip
Fixed #4039 -- added a python_requires to setup.py (#4064)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index b9186a84..9250e2da 100644
--- a/setup.py
+++ b/setup.py
@@ -283,6 +283,8 @@ setup(
packages=find_packages(where="src", exclude=["_cffi_src", "_cffi_src.*"]),
include_package_data=True,
+ python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*',
+
install_requires=[
"idna >= 2.1",
"asn1crypto >= 0.21.0",