aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorOfek Lev <ofekmeister@gmail.com>2017-02-08 00:09:41 -0500
committerPaul Kehrer <paul.l.kehrer@gmail.com>2017-02-08 13:09:41 +0800
commit0e6a129724b707ebf79149376251e85fad550414 (patch)
tree4dde35c726fa6e611d46ef84823c77050b9cb83c /setup.py
parent1c7bd66eef4075888a5a2c2d80ec9a67f62fec08 (diff)
downloadcryptography-0e6a129724b707ebf79149376251e85fad550414.tar.gz
cryptography-0e6a129724b707ebf79149376251e85fad550414.tar.bz2
cryptography-0e6a129724b707ebf79149376251e85fad550414.zip
replace pyasn1 with asn1crypto (#3361)
* replace pyasn1 with asn1crypto * allow trailing bytes * fix x509 test * update CHANGELOG.rst * fix assert * make asn1crypto code more idiomatic * find tag * final clean-up * leave trailing byte logic unchanged * document dependency change * spelling * fix spelling
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 8419e6a7..1b1ff608 100644
--- a/setup.py
+++ b/setup.py
@@ -35,7 +35,7 @@ VECTORS_DEPENDENCY = "cryptography_vectors=={0}".format(about['__version__'])
requirements = [
"idna>=2.0",
- "pyasn1>=0.1.8",
+ "asn1crypto>=0.21.0",
"six>=1.4.1",
"setuptools>=11.3",
]
@@ -61,7 +61,6 @@ test_requirements = [
"pytest>=2.9.0",
"pretend",
"iso8601",
- "pyasn1_modules",
"pytz",
]
if sys.version_info[:2] > (2, 6):