aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2018-09-06 22:56:46 -0500
committerAlex Gaynor <alex.gaynor@gmail.com>2018-09-06 23:56:46 -0400
commit0322962e143798fa5228f4505eeb606cdf773b87 (patch)
tree4cf5c56697f7e7f54d3166425cb180f8f6efe458 /setup.py
parentf88aea5d8b9452677bd23a9bba917b900cd634c0 (diff)
downloadcryptography-0322962e143798fa5228f4505eeb606cdf773b87.tar.gz
cryptography-0322962e143798fa5228f4505eeb606cdf773b87.tar.bz2
cryptography-0322962e143798fa5228f4505eeb606cdf773b87.zip
update pytest config (#4463)
* update pytest config pytest 3.8.0 was just released and officially deprecates some of the way we do pytest marks. They introduced a new way to do this in 3.6 so this PR switches to that mechanism and updates our minimum pytest requirement * update the stubs * also update wycheproof test config to remove deprecated paths * don't need this any more
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8bd31bd5..0c793e32 100644
--- a/setup.py
+++ b/setup.py
@@ -54,7 +54,7 @@ if platform.python_implementation() == "PyPy":
)
test_requirements = [
- "pytest>=3.2.1,!=3.3.0",
+ "pytest>=3.6.0",
"pretend",
"iso8601",
"pytz",